Project

General

Profile

Feature #10497

Make timeout configurable via environment variable

Added by Thomas Lotze about 8 years ago. Updated over 5 years ago.

Status:
Fix released
Priority:
Low (P4)
Assignee:
-
Category:
API/Selenese
Target version:
-
Start date:
Due date:
% Done:

100%

Estimated time:
Keywords:

Description

The timeout used by selenese to wait for events in the UI should be more easily controllable, maybe via an environment variable or more locally per test or per test-case class. This would allow making it as short as possible by default or at least in a non-interactive execution environment like on the Jenkins server, but setting it to something long when a developer needs the time for debugging.


Related issues

Related to gocept.selenium - Bug #10750: Apply the configured timeout consistentlyFix released

Associated revisions

Revision 597:2fcc6872fe22 (diff)
Added by Wolfgang Schnerring over 6 years ago

Re #10497: Move instantiating Selenese object from testSetUp to layer setUp

Revision 598:9a8abb924a1f (diff)
Added by Wolfgang Schnerring over 6 years ago

Fixes #10497: Make timeout configurable via environment variable

History

#1 Updated by Christian Zagrodnick over 7 years ago

self.selenium.setTimeout(7500) ?

#2 Updated by Wolfgang Schnerring over 7 years ago

  • Category set to API/Selenese

#3 Updated by Wolfgang Schnerring over 7 years ago

  • Status changed from New to Confirmed

#4 Updated by Wolfgang Schnerring over 7 years ago

  • Priority changed from Normal (P3) to Low (P4)

#5 Updated by Florian Pilz over 6 years ago

Fände ich gerade auch sehr praktisch, daher push. Oder gibt es das mittlerweile? Default Timeout von 30s ist bei 90s Laufzeit für alle Tests doch recht lang.

#6 Updated by Wolfgang Schnerring over 6 years ago

  • Subject changed from Make timeout externally controllable to Make timeout configurable via environment variable

The timeout is externally configurable Selenese.setTimeout (needs to be done in TestCase.setUp, since the Selenese object is recreated for each test run).

We might want to offer a GOCEPT_SELENIUM_TIMEOUT variable for convenience, though.

#7 Updated by Wolfgang Schnerring over 6 years ago

  • Status changed from Confirmed to Fix committed
  • % Done changed from 0 to 100

Applied in changeset 9a8abb924a1f.

#8 Updated by Wolfgang Schnerring over 5 years ago

  • Status changed from Fix committed to Fix released

2.1.0

Also available in: Atom PDF