Project

General

Profile

Feature #11323

Use random port for application server

Added by Wolfgang Schnerring over 7 years ago. Updated about 7 years ago.

Status:
Fix released
Priority:
Normal (P3)
Assignee:
-
Category:
-
Target version:
-
Start date:
Due date:
% Done:

100%

Estimated time:
Keywords:

Description

Especially in CI environments it would be very useful to be able to run several tests with gocept.selenium in parallel -- which requires that the app server not listen on the same, hard-coded port.

Opening port 0 makes the Kernel to open a (guaranteed available) random port, we just need to figure out how to get the actual port number, since we need to tell it to the browser.

Associated revisions

Revision 373:5f6cf961f18b (diff)
Added by Christian Zagrodnick over 7 years ago

Open a random port for the server process by default

When the environment variable `GOCEPT_SELENIUM_APP_PORT` is not set, a random
free port is bound. This allows parallel testing, for instance (re #11323).

Revision 376:7c71b60680ff (diff)
Added by Christian Zagrodnick over 7 years ago

re #11323: fix auto port bind for ztk integration

Revision 377:787c20e755cf (diff)
Added by Christian Zagrodnick over 7 years ago

re #11323: autobind for plonetesting integration

History

#1 Updated by Christian Zagrodnick over 7 years ago

  • Status changed from Confirmed to Fix committed

hah!

#2 Updated by Wolfgang Schnerring about 7 years ago

  • Status changed from Fix committed to Fix released

gocept.selenium-0.16

Also available in: Atom PDF