Project

General

Profile

Feature #12247

Screenshot on every AssertionError

Added by Michael Howitz about 7 years ago. Updated over 6 years ago.

Status:
Fix released
Priority:
Normal (P3)
Assignee:
-
Category:
-
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
4.00 h
Keywords:

Description

To be able to see what's the error it would be nice to have a screenshot of the whole browser window on every assertion error.

Associated revisions

Revision 564:629aef633c30 (diff)
Added by Michael Howitz almost 7 years ago

If an ``AssertionError`` occures in a test using webdriver, a screenshot is taken automatically and the path is presented to the user. (re #12247)

Revision 565:603c2cb8fa95 (diff)
Added by Michael Howitz almost 7 years ago

fixed test due to re #12247

History

#1 Updated by Sebastian Wehrmann about 7 years ago

  • Status changed from New to Confirmed
  • Priority changed from High (P2) to Normal (P3)
  • Target version set to 2.x
  • Estimated time set to 4.00 h

#2 Updated by Michael Howitz almost 7 years ago

  • Status changed from Confirmed to Fix committed
  • % Done changed from 0 to 100

#3 Updated by Wolfgang Schnerring over 6 years ago

  • Status changed from Fix committed to Fix released

gocept.selenium-2.0.0

Also available in: Atom PDF