Project

General

Profile

Feature #6493

Integrate WebDriver

Added by Wolfgang Schnerring about 11 years ago. Updated about 7 years ago.

Status:
Fix released
Priority:
High (P2)
Assignee:
-
Category:
Backend RC
Target version:
Start date:
2009-11-17
Due date:
% Done:

100%

Estimated time:
Keywords:

Description

Plan for new Webdriver backend: Enable using both backends in the same project.

  • split off HTTP server layers (#8448) into gocept.httserverlayer, and release gocept.selenium-1.1 based on this.
  • Make new package gocept.webdriver that provides a layer on top of httpserverlayer to start the browser using webdriver.
  • Either provide a Selenese API backed by Webdriver (see branch 6493-webdriver) or create a new API (possibly based on webdriverplus, see #11628)

Related issues

Related to gocept.selenium - Feature #8448: Split off HTTP test infrastructure flavoursFix released2010-12-21

Associated revisions

Revision 421:4de677c4fa06 (diff)
Added by Wolfgang Schnerring about 8 years ago

Re #6493: Implement mouseDown/UpRight in terms of webdriver

Revision 483:4d5d8e526190 (diff)
Added by Wolfgang Schnerring almost 8 years ago

Re #6493: Add layer for webdriver backend

This integrates the code developed on feature branch 6493-webdriver as of
c2898ce824ae. Since we changed directions mid-flight, and want to
add webdriver, instead of replacing the existing backend, a VCS merge
of that branch isn't feasible (and its history consists mostly of
"implement some more Selenese API on the new backend")

History

#1 Updated by Wolfgang Schnerring about 11 years ago

  • Status changed from New to Confirmed

#2 Updated by Wolfgang Schnerring almost 10 years ago

  • Priority changed from Normal (P3) to Low (P4)

#3 Updated by Wolfgang Schnerring almost 10 years ago

  • Priority changed from Low (P4) to Normal (P3)

#4 Updated by Wolfgang Schnerring almost 9 years ago

  • Target version set to 2.0

#5 Updated by Wolfgang Schnerring almost 9 years ago

  • Priority changed from Normal (P3) to High (P2)

#6 Updated by Wolfgang Schnerring almost 8 years ago

  • Description updated (diff)

#7 Updated by Wolfgang Schnerring almost 8 years ago

  • Status changed from Confirmed to Fix committed

#8 Updated by Wolfgang Schnerring about 7 years ago

  • Status changed from Fix committed to Fix released

gocept.selenium-2.0.0

Also available in: Atom PDF