Project

General

Profile

Feature #7653

Cage browser in an xnest window

Added by Thomas Lotze over 10 years ago. Updated about 10 years ago.

Status:
Rejected
Priority:
Normal (P3)
Assignee:
-
Category:
-
Target version:
-
Start date:
2010-07-14
Due date:
% Done:

0%

Estimated time:
Keywords:

Description

It would be very relieving if a selenium test run could be made to open the browser against an xnest server. That way, everything would happen within a window on the desktop and no browser windows would pop up all the time, stealing focus and cluttering the screen. See also <http://www.alittlemadness.com/2009/03/10/caging-selenium-with-xnest/&gt;, for example.


Related issues

Is duplicate of gocept.selenium - Feature #6483: Write documentationFix released2009-11-17

Actions
#1

Updated by Wolfgang Schnerring about 10 years ago

  • Status changed from New to Confirmed

This is something that needs to be done on the server side of selenium, so gocept.selenium doesn't really have anything to contribute here. I think we want to document this somewhere, though.

Xnest :1
export DISPLAY=:1
java -jar selenium-server.jar
#2

Updated by Wolfgang Schnerring about 10 years ago

  • Status changed from Confirmed to Rejected

goes into #6483

Also available in: Atom PDF