Project

General

Profile

Feature #8376

Combine waitForElement and other assertions/actions

Added by Wolfgang Schnerring over 9 years ago. Updated over 7 years ago.

Status:
Rejected
Priority:
Normal (P3)
Assignee:
-
Category:
API/Selenese
Target version:
-
Start date:
2010-11-30
Due date:
% Done:

0%

Estimated time:
Keywords:

Description

Various assertions (and actions of course) will choke if the element they look for does not exist, so you need to, for example:

s.waitForElementPresent(locator)
s.waitForVisible(locator)

It would be nice if our Selenese could build the waitForElementPresent in somehow.
(We'll need to be careful in which ways we deviate from the real Selenese, though.)


Related issues

Has duplicate gocept.selenium - Bug #6933: waitForText breaks when Element doesn't exist yetRejected2010-03-03

Is duplicate of gocept.selenium - Feature #11628: Rethink Selenese APIRejected

History

#1 Updated by Wolfgang Schnerring over 9 years ago

  • Subject changed from Combine waitForElement and action to Combine waitForElement and other assertions/actions

#2 Updated by Wolfgang Schnerring over 7 years ago

Webdriver has implicit wait, that's the perfect thing here.

#3 Updated by Wolfgang Schnerring over 7 years ago

  • Target version set to 517

#4 Updated by Wolfgang Schnerring over 7 years ago

  • Status changed from Confirmed to Rejected

we won't do this in the Selenese API. A new API will have this (#11628)

#5 Updated by Wolfgang Schnerring over 7 years ago

  • Target version deleted (517)

Also available in: Atom PDF